Quick Links: Download Gideros Studio | Gideros Documentation | Gideros community chat | DONATE
I can't publish custom plugins for iOS — Gideros Forum

I can't publish custom plugins for iOS

I wrote a custom plugin 3 years ago for a project which exported and worked fine using a version of Gideros in 2018. In a completely different project using same plugin I get the following error when I package the project in iOS.

Lua error:./Tools/export_ios.lua:156: Error: group GroupIOSSupport is not defined (yet)

Using version 2021.9

The same error appears when I compile the 3 year old project.


  • hgy29hgy29 Maintainer
    Accepted Answer
    A few changes have been made to iOS export functions to accomodate with new native MacOS export. I think your .gplugin file has to be updated consequently. If you took one of the default plugins as an example for your plugin, it should be easy to see what have changed

    Likes: SinisterSoft

    +1 -1 (+1 / -0 )Share on Facebook
Sign In or Register to comment.