Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Problems with Admob integration - Gideros Forum

Problems with Admob integration

I'm trying to export and build Android app with Gideros 2018.10


At first i get gradle error:

Error:Failed to resolve: play-services-ads

If i'm changing implementation 'com.google.android.gms:play-services-ads:12.0.1' to implementation 'com.google.android.gms:play-services-ads:12.0.0' or implementation 'com.google.android.gms:play-services-ads:17.0.0'
i'm getting error
Error:(21, 37) error: cannot find symbol class GoogleApiAvailability

Steps: Open project, add Ads plugin with Admob and Unity, Export, Open with Android Studio.
Tagged:

Comments

  • If you have installed the latest google sdk/tools then try 16.0.0 for all of the google play libs as 12.0.1 has been depreciated by google.
    Coder, video game industry veteran (since the '80s, ❤'s assembler), arrested - never convicted hacker (in the '90s), dad of five, he/him (if that even matters!).
    https://deluxepixel.com
  • 16 doesn't help. Same as 15.
    Versions upper 15 doesn't has
    import com.google.android.gms.common.ConnectionResult;
    import com.google.android.gms.common.GoogleApiAvailability;

    Versions lower 12.0.1 doesn't has
    import com.google.android.gms.ads.reward.RewardItem;
    import com.google.android.gms.ads.reward.RewardedVideoAd;
    import com.google.android.gms.ads.reward.RewardedVideoAdListener;

    Our plugin has both.

    How to use it? It looks like it is impossible to publish something with Google Ads.
    If somebody has success, please, share with me solution.
    Thank you!
  • Make sure you change ALL the google play numbers to 16.0.0 - even those not in ads.

    Also load up Android Studio and make sure you are using the latest Android SDK and tools.
    Coder, video game industry veteran (since the '80s, ❤'s assembler), arrested - never convicted hacker (in the '90s), dad of five, he/him (if that even matters!).
    https://deluxepixel.com
  • hgy29hgy29 Maintainer
    I admit I didn’t test AdMob recently, maybe gideros support code for AdMob needs to be updated ? Try with unity ads alone, I know it works because I released a game with unity support and latest gideros in the past month.
  • Unity works well. Admob has no success.

    It is not really great option to limit project by Unity(I still use banners, for example). And it is risky to use only 1 framework in project.
  • Ok so something is wrong here. I'm having the same issue. Managed to export my game with Admob but the moment I run the app on a device it crashes (works well on the player). I will try Unity ads as well, see how they work, but this has to be addressed sooner or later.
  • hgy29hgy29 Maintainer
    @unlying yes, but don’t blame anyone here for not doing it, we do what we can and I test what I need personally
  • I use Unity and AppLovin - no issues with either. :)
    Coder, video game industry veteran (since the '80s, ❤'s assembler), arrested - never convicted hacker (in the '90s), dad of five, he/him (if that even matters!).
    https://deluxepixel.com
  • I don't blame you or anybody. I just hope that somebody has solution and can share it.
    For me easiest solution is to use older version of admob plugin.
  • @unlying, if it crashes on android device then connect it via USB cable, load up Android Studio and then run the app. You should see more specific crash information in LogCat.

    Likes: SinisterSoft

    +1 -1 (+1 / -0 ) Share on Facebook
  • @unlying I used logcat and well the problem might not be what we initially thought. Did you by any chance make your project with Gideros 2017 or a version prior to it? Because if so, you may have the same problem I had. And so I may have a solution to yours.
  • I don't have crashes.

    As i said in first message, i have error:"error: cannot find symbol class GoogleApiAvailability
    "
    error: cannot find symbol variable GoogleApiAvailability
  • YanYan Member
    edited November 2018
    Same to me, I was using 2018.3 and everythings works fine (using gps 9.0.2), ive updated today to latest build and cant do export because I have same errors.

    Very annoying, wanted to publish game this week :'(


    Tried 16.0.0 works fine Admob REQUIREs Gaming plugin set on 16.0.0
    vk.com/yan_alex
  • gemboy100gemboy100 Member
    edited January 2019
    i changed :

    dependencies {
    implementation files('libs/gideros.aar')
    //TAG-DEPENDENCIES//
    implementation 'com.android.support:multidex:1.0.3'
    implementation 'com.google.android.gms:play-services-ads:16.0.0'
    }
    to this:

    dependencies {
    implementation files('libs/gideros.aar')
    //TAG-DEPENDENCIES//
    implementation 'com.android.support:multidex:1.0.3'
    api 'com.google.android.gms:play-services-auth:16.0.0'
    api 'com.google.android.gms:play-services-ads:16.0.0'
    api 'com.google.android.gms:play-services-games:16.0.0'
    }
    and then it works

    Likes: Apollo14, unlying, pie

    +1 -1 (+3 / -0 ) Share on Facebook
  • Could you submit this change to the plugin in github?

    Likes: unlying

    Coder, video game industry veteran (since the '80s, ❤'s assembler), arrested - never convicted hacker (in the '90s), dad of five, he/him (if that even matters!).
    https://deluxepixel.com
    +1 -1 (+1 / -0 ) Share on Facebook
  • It really works!
Sign In or Register to comment.