Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Sovled - Issue with Lua File System missing on Android Export. App crashes - module 'lfs' not found - Gideros Forum

Sovled - Issue with Lua File System missing on Android Export. App crashes - module 'lfs' not found

kussakovkussakov Member
edited October 2017 in General questions
Guys,

When I export my project to open in Android studio and try to run the app - it crashes:

com.giderosmobile.android.player.LuaException: classes/URLImage.lua:11: module 'lfs' not found:
no field package.preload['lfs']
no file './lfs.lua'
no file '/usr/local/share/lua/5.1/lfs.lua'
no file '/usr/local/share/lua/5.1/lfs/init.lua'
no file '/usr/local/lib/lua/5.1/lfs.lua'
no file '/usr/local/lib/lua/5.1/lfs/init.lua'
no file './lfs.so'
no file '/usr/local/lib/lua/5.1/lfs.so'
no file '/usr/local/lib/lua/5.1/loadall.so'
stack traceback:
classes/URLImage.lua:11: in main chunk
(luac): in main chunk
at LUA.MAIN_CHUNK(classesURLImage.lua:11)
at LUA.MAIN_CHUNK(luac:1234)
The line it crashes has:
require("lfs")

Gideros version: 2017.09

Am I missing something? It used to work with my prior version and in emulator.

Please advise.

Cheers

Vlad

Comments

  • kussakovkussakov Member
    edited October 2017
    Same problem with "bit".
    require("bit")

    Runs in the emulator.
    com.giderosmobile.android.player.LuaException: utils.lua:17: module 'bit' not found:
    no field package.preload['bit']
    no file './bit.lua'
    no file '/usr/local/share/lua/5.1/bit.lua'
    no file '/usr/local/share/lua/5.1/bit/init.lua'
    no file '/usr/local/lib/lua/5.1/bit.lua'
    no file '/usr/local/lib/lua/5.1/bit/init.lua'
    no file './bit.so'
    no file '/usr/local/lib/lua/5.1/bit.so'
    no file '/usr/local/lib/lua/5.1/loadall.so'
    stack traceback:
    utils.lua:17: in main chunk
    (luac): in main chunk
    at LUA.MAIN_CHUNK(utils.lua:17)
    at LUA.MAIN_CHUNK(luac:1234)
    I am guess I am doing something wrong. But what?
  • OK. Figured it out.
    My fault.
    In the new version I have to add ALL the plugins manually (Even the old default ones)...
    Never mind...

    (I would delete the discussion, if I could, but maybe someone has similar issue if he hadn't upgraded Gideros in some time)

    Likes: SinisterSoft

    +1 -1 (+1 / -0 ) Share on Facebook
  • Hello! I'm having this issue and I had to find outer here 'cause there's nothing in here explainable. Because of a simply stupid 'require bit' my project doesn't compile into android device... i'm dissapointed for not find anything helpful
Sign In or Register to comment.