Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Game crash - Gideros Forum

Game crash

zimarriozimarrio Member
edited March 2015 in General questions
My game is almost ready for publishing but I found out that sometimes, after playing for a while, the app crashes.
I have no idea what might be happening and I can't figure it out.
How can I find the source of the problem?
Any help would be really appreciated.
This is what I get from logcat:

W/AudioPolicyManager( 274): unregisterEffect() unknown effect ID 6763

F/libc ( 7994): Fatal signal 11 (SIGSEGV), code 1, fault addr 0x90008 in tid 8046 (GLThread 16765)

I/DEBUG ( 270): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***

I/DEBUG ( 270): Build fingerprint: 'motorola/falcon_retgb/falcon_umts:5.0.2/LXB22.46-28.1/1:user/release-keys'

I/DEBUG ( 270): Revision: 'p3c0'

I/DEBUG ( 270): ABI: 'arm'

I/DEBUG ( 270): pid: 7994, tid: 8046, name: GLThread 16765 >>> com.mygamename <<<

I/DEBUG ( 270): signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 0x90008

I/DEBUG ( 270): r0 0008000a r1 00000017 r2 00000000 r3 00090008

I/DEBUG ( 270): r4 b7282ee4 r5 b7282f00 r6 00000000 r7 00090008

I/DEBUG ( 270): r8 b7165f5c r9 00000017 sl b7282ed8 fp 00000017

I/DEBUG ( 270): ip a6ed6c74 sp a6a0b770 lr a6d570c9 pc a6d56fb0 cpsr 00030030

I/DEBUG ( 270):

I/DEBUG ( 270): backtrace:

I/DEBUG ( 270): #00 pc 00068fb0 /data/app/com.mygamename-2/lib/arm/libgideros.so (gevent_CallbackList::dispatchEvent(int, void*)+47)

I/DEBUG ( 270): #01 pc 000690c7 /data/app/com.mygamename-2/lib/arm/libgideros.so (gevent::EventManager::tick()+90)

I/DEBUG ( 270): #02 pc 001553b3 /data/app/com.mygamename-2/lib/arm/libgideros.so

I/DEBUG ( 270): #03 pc 0000bc88 /data/app/com.mygamename-2/lib/arm/liblua.so

I/DEBUG ( 270): #04 pc 0000bf8c /data/app/com.mygamename-2/lib/arm/liblua.so

I/DEBUG ( 270): #05 pc 00005dd8 /data/app/com.mygamename-2/lib/arm/liblua.so

I/DEBUG ( 270): #06 pc 00009920 /data/app/com.mygamename-2/lib/arm/liblua.so

I/DEBUG ( 270): #07 pc 00009a40 /data/app/com.mygamename-2/lib/arm/liblua.so (lua_pcall+76)

I/DEBUG ( 270): #08 pc 000f6273 /data/app/com.mygamename-2/lib/arm/libgideros.so (lua_pcall_traceback+130)

I/DEBUG ( 270): #09 pc 001559c9 /data/app/com.mygamename-2/lib/arm/libgideros.so (LuaApplication::enterFrame(GStatus*)+64)

I/DEBUG ( 270): #10 pc 00065637 /data/app/com.mygamename-2/lib/arm/libgideros.so (ApplicationManager::drawFrame()+142)

I/DEBUG ( 270): #11 pc 000119a1 /data/dalvik-cache/arm/data@app@com.mygamename-2@base.apk@classes.dex

Comments

  • Here some advices.
    Is the game crashes in certain point or not?
    Try the gideros desktop player.
    Is the game crashes in Gideros desktop player? if the answer is yes, try lua debugging.
  • Hi @anim13a,
    I've only seen it crash twice and it doesn't seem to be in a particular point.
    Since yesterday, I've played more than 1 hour, doing everything that came to mind, and couldn't get it to crash, the only clue I have is that log.
    Is desktop and Gideros players I didn't see it crash but it could be because I don't play for hours on them, just a few minutes.
    On iOS I've never seen it crash, but also didn't play for such long periods.
  • piepie Member
    @zimarrio
    This seems a good resource to me to start understanding logCat: :)
    http://forum.xda-developers.com/showthread.php?t=2274119

    I would say that the problem occurs here:
    W/AudioPolicyManager( 274): unregisterEffect() unknown effect ID 6763

    which with good chances generates:
    F/libc ( 7994): Fatal signal 11 (SIGSEGV), code 1, fault addr 0x90008 in tid 8046 (GLThread 16765) - http://en.wikipedia.org/wiki/Segmentation_fault

    and then all the other debug informations
    I/....


    from the previous link:
    W/     Warning - Warnings are basically errors, but less severe. Usually it will show you missing resources, conflicting or missing paths, etc...
     
    F/       Fatal Error - pretty self explanatory
     
    I/        Information - This is pretty tricky, the information class shows what the system is doing, but it can also show you errors so read it carefully!

    Since we're speaking of AudioPolicyManager:

    https://android.googlesource.com/platform/frameworks/av/+/2f8a36fc8df14cba33fa7c5c1c9d5a52f8a133c2/services/audiopolicy/AudioPolicyManager.cpp

    line #1323 - your error is in #1327

    I would say that you have a problem with some sound, which somewhere is not referenced/pointed to correctly.

    I believe that a similar issue could be reproduced on every device, unless there is a bug in Android AudioPolicyManager.

    I would focus on sounds that are not played frequently (and their related code), and try to narrow my search reproducing the issue.

    I know it's not much, but at least you have something to start with.. :)

    %%- good luck!
  • @pie, I commented everything related with sounds and I'm testing to see if the problem persists. The thing is, I only have 3 different sounds and I only instantiate them when the application loads. Also, I've seen it crash when no sound was supposed to be playing.
    Well, I'll keep trying... Thanks for the help!
Sign In or Register to comment.