Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Important notification: Minimum Android version >= 2.2 - Gideros Forum

Important notification: Minimum Android version >= 2.2

gorkemgorkem Maintainer
edited January 2012 in Roadmap

Hi,

As you may be aware from the last blog post, we had to upgrade to Android 2.2, and increase the API Level to 8:

"And last but not least, we’ll be switching to Android 2.2 (API Level 8) starting from the next release. This is required for tablets whose default orientation is landscape, in order to swap the x and y values of the accelerometer (e.g turn 90 degrees clockwise), so apps using the accelerometer will operate correctly. Well, you guessed it – there’s no such function that we can use to understand the default orientation of an Android 2.1 tablet, and this function is right there in Android 2.2 (API Level 8). Therefore due to technical constraints, we had to upgrade the minimum SDK version. This means that your apps will not work with Android 2.1 and below"

We are trying hard to make sure that Gideros Studio supports a wide list of devices, and your applications can work with full performance on even low end Androids. However, due to a lack of a specific function, beta7 is the last version with Android 2.1 support, and we upgraded to Android 2.2 starting from our stable release (due February 7th).

Thanks for your patience and understanding.

Görkem






Likes: MikeHart, john_t

Dislikes: zoul0813

+1 -1 (+2 / -1 ) Share on Facebook

Comments

Sign In or Register to comment.