Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Problem with exported iOS project with Ads interface with Gideros Studio 2018-10 - Gideros Forum

Problem with exported iOS project with Ads interface with Gideros Studio 2018-10

Until recently I’ve monetized my Gideros apps entirely through in-app purchases, but I’m rolling out an update to one app with AdMob monetization. By adding the Ads plugin to the project in Gideros Studio (2018-10), the Android APK exports just fine and ads work as expected. Exporting a project for iOS, X-Code 9 shows the error:

Parse Issue: Umbrella header “GoogleMobileAds.h” not found, module.modulemap

I’ve tried making the search paths for frameworks, headers, and libraries recursive, and other experiments, but I’ve yet to get the iOS project to build.

I’ve consulted the documentation for the Ads interface (docs.giderosmobile.com/interface/ads), but it seems to be out of date, with the installation sections describing the old method of using plugins, by copying src and libs folders into an exported project for Eclipse, and manually modifying the project manifest, etc. It’s great that this is no longer necessary, now that the standard plugins can be added to a project via the Plugins folder within Gideros Studio.

Am I missing something? Is there something else that has to be adjusted in the project to build an iOS export with the Ads interface?

Paul

Comments

  • totebototebo Member
    edited October 26
    Edit: Maybe you also need the Gaming plugin? I seem to remember that there is a dependency for some reason.
    My Gideros games: www.totebo.com
  • PaulHPaulH Member
    Yes, I discovered that dependency when building the Android version, so I've got Gaming in the project already. I'm also using Iab, JSON, and LuaFileSystem.
  • PaulHPaulH Member
    But there seems to be something additional missing, or something that needs tweaking in the iOS project.
  • hgy29hgy29 Maintainer
    Can you check your export log in gideros studio for archive extraction problems ?
  • PaulHPaulH Member
    There are no errors or warnings in the export log. The header in question is present in the export, at (project)\Plugins\Ads\frameworks\GoogleMobileAds.framework\Versions\A\Headers\GoogleMobileAds.h. I'm currently updating to Xcode 10 to see if that makes a difference.
  • PaulHPaulH Member
    Same thing on Xcode 10. One thing that seems odd to me: In the folder \Plugins\Ads\frameworks\GoogleMobileAds.framework there's a file called Headers that the Mac thinks is an executable, and another called GoogleMobileAds. They don't actually run, and there aren't any header files in that folder, though I gather it's common to have a header file there with the same root name as the framework.

    I'm doing the export from Gideros Studio on a PC and transferring the exported project to a Mac, as I've always done. I could try installing Gideros Studio on the Mac and doing the export there, if there's a chance that might help.
  • NatWobbleNatWobble Member
    edited October 27
    I'm not at the mac right now, but I'm pretty sure there should only be one framework.

    I've had similar issues before - you click on the framework and can't see any folders or file within it when they should be there. Have you tried removing it from the project (removing references only) and then adding it again with the "create groups" button selected?

    Also, I've tried exporting a project into a google drive folder before and that causes problems with xcode too. So if you're transferring the project using that (or dropbox or anything similar) then I'd do it manually. I've never tried doing an export on PC and transferring it to mac, though, so maybe you have an issue there.

  • PaulHPaulH Member
    Thanks for the suggestions. I'll give both a try. I'll start with removing references to the framework, and adding it again.

    I always transfer exported projects via thumb drive, but I'll try doing the export on the Mac, too. I have Gideros downloading to the Mac now.
  • Using Sourcetree with bitbucket is a great way to sync your project from PC to Mac with the added bonus of version control.
  • hgy29hgy29 Maintainer
    Accepted Answer
    Paul, transferring from a pc may indeed be the issue. Remember that windows don’t handle symlinks, which are heavily used on Mac on the other hand. The zip extractor contained in gideros may not be able to make those symlinks on windows.
  • PaulHPaulH Member
    Yes, that seems to be the issue. By copying the Gideros project to the Mac and exporting it to the Xcode project there, the project builds just fine. Thanks!
Sign In or Register to comment.