Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
My experience with Gideros mobile. - Gideros Forum

My experience with Gideros mobile.

kinrpgkinrpg Member
edited July 2016 in User experience
I have an notebook dell with Intel core i5 computer with 4GB ram Video Intel HD 3000, windows 7 64bit and Ubuntu 16.04 to 07.01.55. All updated drivers.

Gideros 2015.12: Exports correctly for all platforms (except html5 but this is agreement). Occasionally Gideros Player crash in windows (rare), with the same game running on android and other perfectly.

Gideros 2016.04: Export for Windows Desktop and HTML5 correctly. All other platforms do not generate the files correctly, error or mometaneamente catches Gideros. Formats in 2015.12 exported no longer works at 2016.04. But HTML5 has \ o /

Gideros 2016.06: Do not run Gideros player. By clicking the "Play" the Gideros player opens pointing to localhost {} :::myip and crash. I could not even test the new particles resources etc ... In this Player settings set to localhost.

Conclusion: Working at 2015.12 and use an installation of the 2016.04 to export html.
Sugerir uma edição

Withdrawing these small setbacks I'm more passionate every day by this tool. Simple, easy to use and with a very helpful and charismatic community. I sought once a friendly platform to create simple and fun games with the language Lua.

Likes: hgvyas123, simwhi

+1 -1 (+2 / -0 ) Share on Facebook

Comments

  • SinisterSoftSinisterSoft Maintainer
    edited July 2016
    @kinrpg: For some reason I had the same problem occur in 2016.6 - I ran the player through Visual Studio Debugger to figure out what made it crash.

    It turns out it was something called 'PlaysTV', a game recording system that was hooking programs so it could capture gameplay. It was thing that was crashing my GiderosPlayer a few seconds after it started or if the mouse was moved a lot.

    I removed it and GiderosPlayer worked fine.

    All I can figure is that a game configuration must look close to GiderosPlayer and the 'playstv' system mis identified it.

    You may have this on your system as I think it's bundled with ATi and possibly Intel drivers. It's also known as Raptr I think. It's also licenced by TwitchTV so it may be in that too.

    Likes: kinrpg

    +1 -1 (+1 / -0 ) Share on Facebook
  • kinrpgkinrpg Member
    Really curious, I would not have imagined something like this. So in some equipment it will stop working and not in others. I think it is waiting for a new version of Gideros then.
  • john26john26 Maintainer
    @kinrpg, thanks for the bug report and sorry you are finding bugs particularly in 2016.6. We've had other reports of bugs and I'm beginning to think it is something to do with OpenGL. We recently added some advanced graphics features and perhaps your version of OpenGL is not high enough to support these. Can you find out what version of OpenGL you are running? If you export a win32 project (eg an example project) run win32.exe and you can see the OpenGL version there.

    Likes: antix, kinrpg

    +1 -1 (+2 / -0 ) Share on Facebook
  • @kinrpg, thanks for the bug report and sorry you are finding bugs particularly in 2016.6. We've had other reports of bugs and I'm beginning to think it is something to do with OpenGL. We recently added some advanced graphics features and perhaps your version of OpenGL is not high enough to support these. Can you find out what version of OpenGL you are running? If you export a win32 project (eg an example project) run win32.exe and you can see the OpenGL version there.
    Hi. This here:

    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.2.0
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 11.2.0
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.2.0
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
    OpenGL ES profile extensions:



    These bugs are small stones on the path of evolution. They are happening because the tool is getting better rs.
    I went back to a previous version and will following the updates :)
  • john26john26 Maintainer
    Thanks, OpenGL 3.3 should be high enough. There is a bug in 2016.6 which is causing Gideros Player to crash on startup, we have fixed this now and will release a new version in the next few days.

    Likes: antix, kinrpg

    +1 -1 (+2 / -0 ) Share on Facebook
Sign In or Register to comment.