Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
building for android - Gideros Forum

building for android

konstantinkonstantin Member
edited October 2011 in General questions
I have exported a sample app in to an android project. I see all the needed sub-directories created, and all the files except for
build.xml
.

So I have created
build.xml
thus:
android update project -p . -t 2
(see below for my target list)

Now when I build with
ant debug
, it gives me an error (among others, which, I think, are caused by this one):
-compile:
    [javac] <img class="emoji" src="/resources/emoji/anguished.png" title="D:" alt="D:" height="20" />\tools\android-sdk\tools\ant\build.xml:600: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 2 source files to C:\Users\root\Documents\Bird Animation\bin\classes
    [javac] C:\Users\root\Documents\Bird Animation\src\com\giderosmobile\android\BirdAnimationActivity.java:13: error: package com.giderosmobile.android.playerdoes not exist
    [javac] import com.giderosmobile.android.player.*;
    [javac] ^
what is wrong?

My targets:
C:\Users\root\Documents\Bird Animation>android list target
Available Android targets:
----------
id: 1 or "android-13"
     Name: Android 3.2
     Type: Platform
     API level: 13
     Revision: 1
     Skins: WXGA (default)
     ABIs : armeabi
----------
id: 2 or "android-14"
     Name: Android 4.0
     Type: Platform
     API level: 14
     Revision: 1
     Skins: HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800 (default), WVGA854, WXGA720, WXGA800
     ABIs : no ABIs.
----------
id: 3 or "Google Inc.:Google APIs:14"
     Name: Google APIs
     Type: Add-On
     Vendor: Google Inc.
     Revision: 1
     Description: Android + Google APIs
     Based on Android 4.0 (API level 14)
     Libraries:
      * com.android.future.usb.accessory (usb.jar)
          API for USB Accessories
      * com.google.android.maps (maps.jar)
          API for Google Maps
     Skins: WVGA854, WQVGA400, WSVGA, WXGA720, HVGA, WQVGA432, WVGA800 (default), QVGA, WXGA800
     ABIs : armeabi-v7a
Sign In or Register to comment.