Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
"Unfortunately, Application has stopped" problem in implementing IAB. - Gideros Forum

"Unfortunately, Application has stopped" problem in implementing IAB.

aimoiaimoi Member
edited September 2015 in Plugins
Hi guys,
I have tried to implement IAB plugin to my application.

As the "Instalitation on Android" in the "Gideros Documentation" has said:
Choose the frameworks you will use and delete all the unneeded based on file dependency table for each framework below

I have tried to delete the dependent files for frameworks that I'm not going to use.
I could easily find and delete the dependent files in directory: "src\com\giderosmobile\android\plugins\". But when it comes to directory: "libs\" I have only image and inside these folders I don't see anything like "in-app-purchasing-1.0.3.jar" or other files mentioned in file dependency table.
Also I can't find and delete "default Google Billing v2 plugin". I do the other parts of the implementation as it has said in the documentation. By the way, after I implement the plugin and when I try to run it on my device via a USB cable, I get "Unfortunately, Application has stopped" error. So do you think what's wrong with my application?

UPDATE #2:
The LogCat filtered by errors and my package name (com.aimdom.aim) is a lot of like this errors:
09-24 15:41:47.767: E/WindowState(881): getStack: Window{2d47b8fc u0 com.aimdom.aim/com.giderosmobile.android.iabtestActivity} couldn't find taskId=18659 Callers=com.android.server.wm.WindowManagerService.performLayoutAndPlaceSurfacesLockedInner:9959 com.android.server.wm.WindowManagerService.performLayoutAndPlaceSurfacesLockedLoop:8991 com.android.server.wm.WindowManagerService.performLayoutAndPlaceSurfacesLocked:8933 com.android.server.wm.WindowManagerService.executeAppTransition:4238
Thank You very much in advance. (:

Comments

  • Can anyone help me with implementing IAP plugin in my apps? I have done exactly what it has said in docs and still I get problems. It's almost a month that I have stuck in this part and I'm wondering if I won't be able to implement IAP I should change my game engine. The sad part is the plugin exists but I can't use it.

    ps. I want to implement it for google play store.
  • Hello, for Google play IAB you don't need additional libs, you only need to link project to Google Play Services.

    Unfortunately cannot get anything from your error, there must be something else, please try to post full logcat

    Likes: aimoi

    +1 -1 (+1 / -0 ) Share on Facebook
  • aimoiaimoi Member
    edited September 2015
    Is there any other thing except what it has been said in here that I should do to "link project to Google Play Services"?

    These are logcats filtered by my package name:
    image
    image

    Thanks a lot for helping. (:
  • ar2rsawseenar2rsawseen Maintainer
    Accepted Answer
    It is possible that the real error is not attributed to your package name for some reason, as I don't see anything relevant error here. Only process is closed and thats it.

    So let's retrace the steps?

    Are you using Eclipse export?

    Then

    1) copy libiab.so files in to respective architecture folders
    2) add System.loadLibrary("iab"); to main activity
    3) add "com.giderosmobile.android.plugins.iab.Iab" to external classes
    4) add permission to manifest:

    5) Copy files in folders android/vending/billing
    giderosmobile/android/plugins/iab

    from giderosmobile/android/plugins/iab/frameworks copy only IabGoogle.java and google folder

    copy all that in to same hierarchical place in your exported project

    6) Build your project

    And it seems I was wrong, it does not even need Google Play Services, sorry have not done it in a while :)

    Likes: aimoi

    +1 -1 (+1 / -0 ) Share on Facebook
  • well, I have done exactly as you had said and I have done all the steps carefully several times.

    Finally I found where was the problem. As you had said in here
    It is possible that the real error is not attributed to your package name for some reason, as I don't see anything relevant error here. Only process is closed and thats it.
    The problem was not about the implementing. As I had to test the app on the real device and I couldn't use the built-in player to test my app, I was not able to see I had used a variable without setting it up. So because of that I was receiving such a error.

    @ar2rsawseen Thank you very much for your help and contribution. (:
Sign In or Register to comment.