Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Compiling plugins with LuaJIT - Gideros Forum

Compiling plugins with LuaJIT

zaniarzaniar Member
edited February 2014 in Plugins
Hi guys. Long time no see ;;)

I am currently playing with the beta version of LuaJIT plugin. I am trying to build a game that using plugin. The build process went successfully, but there was a problem when it runs. Here is the message from LogCat:
02-27 10:54:02.873: E/AndroidRuntime(13943): Caused by: java.lang.UnsatisfiedLinkError: Cannot load library: soinfo_link_image(linker.cpp:1635): could not load library "libluajit-5.1.so.2" needed by "libopenfb.so"; caused by load_library(linker.cpp:745): library "libluajit-5.1.so.2" not found
I guess I need a new lua.h.

Can anyone give me some direction?

Comments

  • @zaniar interesting I don't think there should be problem directly with the luajit, as binaries are named the same and your plugin should only link binary

    I think what you might have are the old header files (even before luajit)

    Try going to gideros installation directory/Sdk/include and use the files that are there (overwriting your existing headers)
  • yes. i had similar error.

    updated sdk (copied from gideros sudio folder)
    and work fine. (with tnt collision)
    (except for my speed problems... ;) )
    TNT ENGiNE for Gideors Studio - Particle Engine, Virtual Pad, Animator Studio, Collision Engine - DOWNLOAD NOW !!! IT'S FREE!!! -
    www.tntengine.com
  • Hmmm.. I think I have copied the newest header :-? . But I will try your suggestion @ar2rsawseen. I will let you know the result.

    Thank you.
  • No joy :(

    I build this app without LuaJIT, and it works fine. The SDK is not the problem I think.

    @GregBUG: Did you use LuaJIT?
  • Well even if it is so, the relation is complicated for now and I won't be able to provide headers for LuaJIT. But we will try to resolve that in future.

    In reality that won't change anything if you built the plugin linking to one or another, they should work with the end binary added to the project
  • @zaniar
    yes
    i compiled the player with luajit and my tntcollision engine with no errors but it's slow.. (luajit)

    i'm making something wrong but i can't figure what! (until now).
    @sinistersoft work all fine (luajit is far far faster than lua and my c code as should be)

    but on my devices (a phone with mtk6589 and samsung tab2 work very very slow...)

    i need to discover why...
    TNT ENGiNE for Gideors Studio - Particle Engine, Virtual Pad, Animator Studio, Collision Engine - DOWNLOAD NOW !!! IT'S FREE!!! -
    www.tntengine.com
  • hmm @GregBUG what your Android.mk file looks like?

    If it is something like this:
    include $(CLEAR_VARS)
     
    LOCAL_MODULE            := lua
    LOCAL_SRC_FILES         := ../../libs/$(TARGET_ARCH_ABI)/liblua.so
     
    include $(PREBUILT_SHARED_LIBRARY)
    Then there is a chance you are overriding copied luajit liblua.so with the default one from the destination provided. Just checking
  • @ar2rsawseen


    mmmm nice shoot...

    now i'm at work... i'll check as soon as i'll go home... .)

    finger crossed....


    but my player work fine on @sinistersoft device....
    TNT ENGiNE for Gideors Studio - Particle Engine, Virtual Pad, Animator Studio, Collision Engine - DOWNLOAD NOW !!! IT'S FREE!!! -
    www.tntengine.com
Sign In or Register to comment.