Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Problem with require "lsqlite3" - Gideros Forum

Problem with require "lsqlite3"

jouderianjrjouderianjr Member
edited September 2013 in Plugins
Hi, this is my first topic here :D

I'm having a problem with lsqlite plugin. If i test in my desktop work's fine, but if i test in my phone(Nexus 4) i have this problem:

./DatabaseManager.lua:11: attempt to index global 'sqlite3' (a nil value)
stack traceback:
./DatabaseManager.lua:11: in function 'test'
main.lua:28: in main chunk
DatabaseManager.lua is uploading.
Uploading finished.
DatabaseManager.lua:1: module 'lsqlite3' not found:
no field package.preload['lsqlite3']
no file './lsqlite3.lua'
no file '/usr/local/share/lua/5.1/lsqlite3.lua'
no file '/usr/local/share/lua/5.1/lsqlite3/init.lua'
no file '/usr/local/lib/lua/5.1/lsqlite3.lua'
no file '/usr/local/lib/lua/5.1/lsqlite3/init.lua'
no file './lsqlite3.so'
no file '/usr/local/lib/lua/5.1/lsqlite3.so'
no file '/usr/local/lib/lua/5.1/loadall.so'
stack traceback:

I already tried see the plugins i have and is really missing lsqlite module:

googlebilling
gyroscope
box2d
lfs
geolocation
accelerometer
socket.core
googlebilling
gyroscope
box2d
lfs
geolocation
accelerometer
socket.core

Any idea guys?

Thank you and sorry for my bad english

Comments

Sign In or Register to comment.