Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat | DONATE
Gideros Player won't work on Android? — Gideros Forum

Gideros Player won't work on Android?

JazoomJazoom Member
edited October 2012 in Bugs and issues

I'm just starting with Gideros. I'm having trouble getting Gideros Player to work on my Android phone. I found one thread talking about this from last December, but it didn't seem to solve my problem.

NOTE: I am connected via wifi, both my computer and the phone - the same network.

I put in the IP as directed in the instructions, but when I click "OK" nothing happens. I can use the "local host" and see an app running, but it just won't work on the phone.

Any suggestions?


  • ar2rsawseenar2rsawseen Maintainer
    edited October 2012
    Can you ping your mobile phone from your PC?

    So couple of scenarios:
    • Android phones may put WiFi connections to sleep, so visit some page in browser to activate it again
    • Both PC and phone needs to be in the same network. For example, if your phone currently uses also 3g connection, it might provide wrong IP address (from 3g network and not local one)
    • Gideros Studio is blocked by firewall, adding GiderosStudio to Firewall exceptions
    • In some networks it simple does not work. For example, I can't make a Gideros player connection in my University network, although my phone and PC connected to it and even can ping each other. Probably some kind of internal network restriction
    • If you think that everything above is ok, then after pushin OK button and when waiting for play button to become active, restart Gideros player on your phone (simply exit and launch it again), and then usually Gideros Studio connects to phone and you are able to push play button

    Likes: atilim

    +1 -1 (+1 / -0 )Share on Facebook
  • Hi ar2rsawseen, thanks for taking the time to reply.

    Yeah, those suggestions are pretty much what were mentioned over on the other thread. I have tried all of them multiple times. I've also disabled Microsoft Security Essentials on my PC. I am at home and there is no reason why my network would block this communication. I can use AirDroid at home with no problems.

    How long is it meant to take to connect and start up? I wait for quite a while and nothing ever happens. I am running Android 4.1.2. Is it possible that it's due to the new version of Android?
  • ar2rsawseenar2rsawseen Maintainer
    edited October 2012
    Oh and I forgot about adding Gideros Studio to Firewall exceptions ;)

    I really doubt it is related to latest Android version, but just in case can you get other device to test?

    And connection is established in the matter of seconds. (if I have to wait for more than 5 seconds, than probably something is not ok :) )

    So can you ping your phone from your PC?
  • Ummmm.... I used my wife's phone (Galaxy S2 running android 2.3) and it worked. It's looking likely that it's the new version of Android. Can anyone else confirm that 4.1.2 works with this feature? I'm using a Galaxy Nexus.
  • Sorry, I forgot to mention I can also ping my phone without a problem.
  • JazoomJazoom Member
    edited October 2012
    So does anyone else have this issue?....

    By the way, what exactly happens if I "Reject" an answer? Is it bad for the person who answered in any way, or does it just make it so my question remains for people to see?
  • So does anyone else have this issue?....

    By the way, what exactly happens if I "Reject" an answer? Is it bad for the person who answered in any way
    not at all feel free to reject and accept answer
  • gorkemgorkem Maintainer
    @jazoom it's much better to accept an answer than reject the remaining as it easily can be misunderstood.
  • Ok thanks both of you. Unfortunately I can't yet mark any answers as accepted because the issue remains :(
  • Hello!
    I'm having a problem on loading my project into my device. Gideros is not transfering the files to my device. I'm trying to run it through gideros player for android but it gives me error that file not found.. Will I have to insert manually the files into the device?

  • maybe you have plugins in the project
    Make your player with the right plugins
    785 x 501 - 67K
    my games:
    мій блог по гідерос https://simartinfo.blogspot.com
    Слава Україні!
Sign In or Register to comment.