Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Failed to build for iOS simulator(library was not compiled for the simulator) — Gideros Forum

Failed to build for iOS simulator(library was not compiled for the simulator)

I got crash on start with latest gideros studio.
I understand that something wrong with... something? But i don't get it what i should change(it is just export->build, no modifications). What library not compatible with simulator? What should i do to run?

Log:
2021-04-02 13:04:08.855263+0300 findword iOS[74190:4317675] Metal GPU Frame Capture Enabled
2021-04-02 13:04:08.855487+0300 findword iOS[74190:4317675] Metal API Validation Enabled
2021-04-02 13:04:08.904574+0300 findword iOS[74190:4317675] [plugin] AddInstanceForFactory: No factory registered for id F8BB1C28-BAE8-11D6-9C31-00039315CD46
2021-04-02 13:04:09.498047+0300 findword iOS[74190:4317965] [aurioc] AURemoteIO.h:323:entry: Unable to join I/O thread to workgroup ((null)): 2
METAL:Apple iOS simulator GPU

/Users/pshchedukhin/Library/Developer/CoreSimulator/Devices/35526540-4C04-4EE3-8638-2EE54FBBE314/data/Containers/Data/Application/2FDBF346-EEC8-462C-B68E-B23EE28729F8/Documents
/Users/pshchedukhin/Library/Developer/CoreSimulator/Devices/35526540-4C04-4EE3-8638-2EE54FBBE314/data/Containers/Data/Application/2FDBF346-EEC8-462C-B68E-B23EE28729F8/tmp/
/Users/pshchedukhin/Library/Developer/CoreSimulator/Devices/35526540-4C04-4EE3-8638-2EE54FBBE314/data/Containers/Bundle/Application/4EFA2BAF-4415-43AB-ABB1-E3C1A904A38C/findword iOS.app
/Users/pshchedukhin/Library/Developer/CoreSimulator/Devices/35526540-4C04-4EE3-8638-2EE54FBBE314/data/Containers/Data/Application/2FDBF346-EEC8-462C-B68E-B23EE28729F8/Library/Caches
2021-04-02 13:04:09.597892+0300 findword iOS[74190:4317675] Reachability Flag Status: -R ------- networkStatusForFlags
2021-04-02 13:04:09.606195+0300 findword iOS[74190:4317675] To get test ads on this device, set: request.testDevices = @[ kGADSimulatorID ];
2021-04-02 13:04:09.694786+0300 findword iOS[74190:4317675] Reachability Flag Status: -R ------- networkStatusForFlags
2021-04-02 13:04:09.700785+0300 findword iOS[74190:4317815] [Client] Updating selectors failed with: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated.}
2021-04-02 13:04:09.700790+0300 findword iOS[74190:4317816] [Client] Synchronous remote object proxy returned error: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated.}
2021-04-02 13:04:09.700997+0300 findword iOS[74190:4317815] [Client] Updating selectors after delegate addition failed with: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated.}
2021-04-02 13:04:09.701592+0300 findword iOS[74190:4317816] [Client] Synchronous remote object proxy returned error: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated.}
2021-04-02 13:04:09.701931+0300 findword iOS[74190:4317815] [Client] Updating selectors failed with: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated.}
2021-04-02 13:04:09.704069+0300 findword iOS[74190:4317815] [Client] Updating selectors failed with: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated.}
2021-04-02 13:04:09.704619+0300 findword iOS[74190:4317816] [Client] Synchronous remote object proxy returned error: Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated." UserInfo={NSDebugDescription=The connection to service on pid 0 named com.apple.commcenter.coretelephony.xpc was invalidated.}
2021-04-02 13:04:09.751817+0300 findword iOS[74190:4317819] [] nw_protocol_get_quic_image_block_invoke dlopen libquic failed
2021-04-02 13:04:09.920548+0300 findword iOS[74190:4317675] Compiler failed to build request
2021-04-02 13:04:09.920895+0300 findword iOS[74190:4317675] Error creating render pipeline state: Error Domain=CompilerError Code=2 "Target OS is incompatible: library was not compiled for the simulator" UserInfo={NSLocalizedDescription=Target OS is incompatible: library was not compiled for the simulator}
-[MTLDebugRenderCommandEncoder validateCommonDrawErrors:instanceCount:baseInstance:maxVertexID:]:4186: failed assertion `renderPipelineState must be set.'
-[MTLDebugRenderCommandEncoder validateCommonDrawErrors:instanceCount:baseInstance:maxVertexID:]:4186: failed assertion `renderPipelineState must be set.'
CoreSimulator 732.18.6 - Device: iPhone 12 (35526540-4C04-4EE3-8638-2EE54FBBE314) - Runtime: iOS 14.4 (18D46) - DeviceType: iPhone 12
(lldb)
Tagged:

Comments

  • hgy29hgy29 Maintainer
    That’s the shader library, the simulator requires a different build of the mtllib. I will try to bundle it from now on, but you’ll still need to replace the one exported by Gideros with the simulator specific one.
  • Thanks. Is it possible to turn off that library from building because i don't use shaders so i don't need it?
  • hgy29hgy29 Maintainer
    Those are Gideros internal shaders, you use them without knowing...
  • hgy29hgy29 Maintainer
    @unlying, I actually already bundle the simulator version of the shader library into the exported project, so you should have it already. It is called default-sim.metallib. Just replace default.metallib with default-sim.metallib (and keep the original default.metallib somewhere for production) and it should work in simulator
Sign In or Register to comment.