Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Android 2.3 and OpenSL ES — Gideros Forum

Android 2.3 and OpenSL ES

atilimatilim Maintainer
edited October 2012 in Roadmap
Hi all,

Currently, we're using a modified version of OpenAL Soft in Android and it provides _almost_ low latency audio playing.

And for some time, I want to move OpenSL ES for lower latency audio, for smaller binary size, for easy debugging and to get rid of Java dependency. But it requires Android 2.3. Currently the distribution of 2.2 is about ~12.9% and decreases steadily [1]. For example, in 04/2012 it was about ~%23. It may be even lower for users who usually play games on their Android devices.

My questions are:
1. Do you have Android 2.2 dependency?
2. Is it ok for you if you lose ~12.9% of market?

Thank you

[1] http://developer.android.com/about/dashboards/index.html

Likes: MobAmuse

+1 -1 (+1 / -0 )Share on Facebook
«1

Comments

Sign In or Register to comment.