Quick Links: Download Gideros Studio | Gideros Documentation | Gideros community chat | DONATE
Gideros Studio in MacOS/Linux - Editor Themes not applying properly — Gideros Forum

Gideros Studio in MacOS/Linux - Editor Themes not applying properly

tyrkanetyrkane Member
edited March 23 in Bugs and issues
Hi All,

Unsure if this has been reported before (I have searched and can't find any topics on this)
Gideros Studio under MacOS or Linux doesn't apply Editor themes properly at all.
(UI Theme works fine)

The default light theme works fine, but as soon as you apply a Dark editor theme, it does this weird black line and doesn't go fully black.
(See attached screenshot of default Light theme and Applying SublimeText3.ini)

I have also tried under a Linux distro and getting the exact same theme bug.
Windows is obviously fine.

Apologies if this is a known issue, feel free to point me in the right direction :smile:

EDIT: Running MacOS Sonoma 14.3.1 -
Also tried on Arch Linux with KDE


Screenshot 2024-03-23 at 8.39.44 am.png
1378 x 950 - 210K
Screenshot 2024-03-23 at 8.40.34 am.png
1376 x 947 - 197K

Likes: MoKaLux, kinrpg

+1 -1 (+2 / -0 )Share on Facebook


  • hgy29hgy29 Maintainer
    It could be because some the keys in the theme's ini files contains backslahes, which are automatically converted to forward slashes on Windows (according to QT doc) but not on other platforms. A possible fix would be to turn them into forward slashes in the ini files.
    Can you try this @tyrkane and let us know ?

    Likes: MoKaLux

    +1 -1 (+1 / -0 )Share on Facebook
  • tyrkanetyrkane Member
    Thanks for the reply - just tried changing all to forward slashes, still same issue :neutral:
  • hgy29hgy29 Maintainer
    Accepted Answer
    @tyrkane, I had a try and it turns out changing backslashes to forward slashes is needed, but not enough. We also need to to have the first part of the keys(before the first slash) in Scintilla section in lower case, which means replacing all Lua/ into lua/ and likewise for other languages

    Likes: MoKaLux, pie

    +1 -1 (+2 / -0 )Share on Facebook
  • tyrkanetyrkane Member
    Thanks again @hgy29, can finally use dark themes outside of Windows :smile: Thanks for pushing it onto the latest release!

    Likes: MoKaLux, hgy29

    +1 -1 (+2 / -0 )Share on Facebook
  • kinrpgkinrpg Member
    edited April 9
    Dark themes are missing from linux. There's also the problem that the text in the gideros studios editor doesn't accept accents in my language, although if I copy an accented text from elsewhere and paste it into the editor, it appears. My alternative is to use an operating system text editor to type in the code, because as soon as I save it, it updates inside gidero studio, then use GS to debug and compile.
Sign In or Register to comment.