Quick Links: Download Gideros Studio | Gideros Documentation | Gideros community chat | DONATE
Library widget disappeared — Gideros Forum

Library widget disappeared

Without the library widget which is normally in the lefthand pane, I cannot open files from Gideros Studio. The attached screenshot shows what this looks like.

I am a new user. I don't know what I could have done to cause this issue. I have tried to reinstall several times, without any luck.

I am working on MacOS Monterey Version 12.6

Thanks for your help.


  • hgy29hgy29 Maintainer
    Accepted Answer
    What would help is delete the settings.ini file, but if I know where to find it on windows, I am not sure where would macOS store it. I think there is an application data folder in the home directory and at root level
  • Maybe the widget has been undocked and now is floating outside of your screen? You could try to resize gideros window, make it small for example a 600 by 600 window (I don't know if it's possible on Mac) then close gideros and reopen it, hopefully you will see the widget.

    We should add a button in the settings to reset gideros layout like we have for reset ui and editor theme?
    my growING GIDEROS github repositories: https://github.com/mokalux?tab=repositories
  • No luck moving around windows or placing and replacing widgets. When I left-click on a widget, I get a contextual menu showing:

    √ Output
    √ Preview
    √ Outline

    I installed into another user account which is a temporary fix.

    I found two folders, one for Plugins and another for Addons in user/library/application support/Gideros, but tossing those out didn't fix the issue.

    I will keep looking for the settings file.

    Likes: MoKaLux

    +1 -1 (+1 / -0 )Share on Facebook
  • Fixed it!

    hgy29 was right.

    In the user directory in the hidden folder .config there was a folder called giderosmobile.com which had a file called GiderosStudio.ini inside.

    Throwing that away fixed the issue.

    Thanks for the help.

    Likes: hgy29, MoKaLux

    +1 -1 (+2 / -0 )Share on Facebook
  • saeyssaeys Member
    edited January 2023
    For future reference for Win11 users; I also had the output widget gone. Right-click menu on a the toolbar showed Output was unchecked and greyed out (why is that?).

    Deleted the GiderosStudio.ini file located in C:\Users\USER\AppData\Roaming\GiderosMobile folder. Restarted Gideros Studio. The recent project list was cleared but all widgets restored. :)

    Likes: MoKaLux

    +1 -1 (+1 / -0 )Share on Facebook
Sign In or Register to comment.