Quick Links: Download Gideros Studio | Gideros Documentation | Gideros community chat | DONATE
Emsdk (emscripten) latest environment not supported? — Gideros Forum

Emsdk (emscripten) latest environment not supported?

Hi, I am trying to build the HTML5 version of Gideros.
(Of course I know I can use Gideros Studio to just export HTML5 projects. However, I want to build directly from the source code.)

I've been following the link below, but after `emsdk install latest`, `emsdk install sdk-incoming-64bit` fails. So I couldn't even install the Gideros fork after it.


Still, I ignored it for now and tried `make -f scripts/Makefile.gid html5.install`, but it was blocked by getting an undefined exported function error while building `$(BUILD)/gideros-wasm.html:`. These functions are clearly in export.list, but it says that they cannot be found irregularly.

Doesn't it support the latest emsdk? Or please let me know what version of emsdk using for building release version of Gideros recently.

My build environment is on msys2 + Windows 10.


  • hgy29hgy29 Maintainer
    Yes, that can happen if you use official emscripten instead of gideros own fork, simply because emscripten has evolved, added new symbols, removed others, etc and it messes up with what was done in gideros to benefit for dead code elimination while ensure some functions are available to plugins. Plus gideros fork has some code changes required for Gideros launch sequence (to support compression and plugin loading mostly).

    If you can't even do a regular emsdk install sdk-incoming-64bit, then something has changed in emscripten and the bulding doc should be updated. Maybe it is time Gideros updates to latest emscripten too.

    Likes: SinisterSoft

    +1 -1 (+1 / -0 )Share on Facebook
  • hgy29hgy29 Maintainer
    Ok, turns out this is a well known issue for emscripten/windows, but nodoby wants to fix it properly yet. It had been that way for years, and I had to tinker with my own windows setup in an ugly way to overcome it. The official fix is to manually install a more recent python version than the one bundled: https://emscripten.org/docs/getting_started/downloads.html#windows
    You'll have to adjust your paths accordingly too
  • Thank you for your answer.

    I don't think that's the case. `Install Python 2.7.12 or newer (older versions may not work due to a GitHub change with SSL).` Is this what you meant?

    When I look at the emsdk environment, the latest version of emsdk is using python 3.7. I modified emsdk.bat and checked the python version used by emsdk, and that's it, 3.7 version like following.

    call "C:\dev\emsdk\python\3.7.4-pywin32_64bit\python.exe" "C:\dev\emsdk\\emsdk.py"

    What I wrote emsdk install fails was like this.

    C:\dev\emsdk>emsdk install sdk-incoming-64bit
    Error: No tool or SDK found by name'sdk-incoming-64bit'.

    In the latest version, I tried `emsdk list`(even older one) there is no such package. I'm not sure if the old emsdk had that, and I haven't been able to find how it was replaced these days. Maybe there is something that I am missing from the emsdk installation. I did what the document told me to do, though.

    Anyway, thanks again for the answer.

    Likes: MoKaLux

    +1 -1 (+1 / -0 )Share on Facebook
  • hgy29hgy29 Maintainer
    Thta's weird, because I just downloaded it again this morning (following the wiki instructions) and when I type 'emsdk list' I can see the sdk-incoming-64bit as a possible SDK. Did you get your emscripten code from the github link on the wiki ?
  • I almost compiled gideros from the wiki :smile:

    my growING GIDEROS github repositories: https://github.com/mokalux?tab=repositories
Sign In or Register to comment.