Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat | DONATE
Launching Gideros Player via command line — Gideros Forum

Launching Gideros Player via command line

I working on making a simple IDE for myself that has auto-completion and syntax highlighting for Gideros APIs (and Lua). I'd like to know if it is possible to launch the player via command line so that my IDE could run the player.

Is this the place to ask this type of question or should I be asking somewhere else?

Likes: Apollo14

+1 -1 (+1 / -0 )Share on Facebook


  • I'm also curious about how to launch player via command line.
    I guess you can do it, some people mentioned that they use Visual Studio for Gideros projects.

    btw did you check ZeroBrane Studio?
    it's the most advanced Lua IDE, and it supports Gideros
    > Newcomers roadmap: from where to start learning Gideros
    "What one programmer can do in one month, two programmers can do in two months." - Fred Brooks
    “The more you do coding stuff, the better you get at it.” - Aristotle (322 BC)
  • tpropertproper Member
    edited January 2019
    I've tried ZeroBrane but I work on a mac and it doesn't launch the player properly about 80% of the time for some reason.

    I wanted to create an IDE so I could see how to make one along with being able to add stuff that I like. ZeroBrane has auto-complete but large files seem to get unorganized because it doesn't highlight (or at least I didn't find a way to highlight things).

    Here is a screen shot of my project so far, to get an idea of what I'm trying to do. Plus, its been a fun project.

    I crawled the reference site to get all the information so I can display it to myself instead of having to look everything up- at least some things I won't have to look up.

    (haven't gotten the highlighting working for the API's yet.)

    Mainly, just an IDE, text editor really, for me. I'll be using Gideros Studio to debug, and set project settings and such, but I'll use my project for code writing.


    Open of the main features I want to add is auto-complete and highlights for my own functions found in other files so I don't have to keep referring back to them to remember the order of parameters and other things like that.
  • hgy29hgy29 Maintainer
    Launching the player is just a matter of launching Gideros Player.app, but I guess you figured that out already. If you want to launch a project on the player, you can use gdrbridge command line utility located in Tools folder (within Gideros Studio.app on Mac)
  • tpropertproper Member
    edited January 2019
    Thanks. I tried that (on windows now) using:

    C:\Program Files (x86)\Gideros\Tools>gdrbridge play C:\Users\spenl\Documents\my_project.gproj
    * daemon not running. starting it now on port 15011 *
    * daemon started successfully *

    But nothing happened. Is there something else I must do?

    Also, is there a way to launch it in debug mode? Say, I have Gideros Studio running and have set a breakpoint. Is it possible to launch the player from command line and have it stop on that breakpoint?
  • ZBS is open source so you can look at it's code to see how Gideros Player is launched as it uses a commandline. I don't have an apple computer but generally on windows when the player does not launch correctly from ZBS it is because Gideros Studio is open.. they clash.

    It's a large job to make your own IDE.. good luck!! I'd most likely contact @paulclinger who is the creator of ZBS (pretty sure about that) and see if he can shed any light on why the player does not launch every time on mac. He is a top notch guy and is always willing to improve ZBS to make it more Gideros friendly!
  • hgy29hgy29 Maintainer
    Before using the play command you should specify the ip/port of the target player. And no debug isn’t supported in gdrbridge. Any help is welcome to add it
  • Ok. Thanks!

    Also, I'll look into ZeroBrane studio's source and see what I can find.
  • check interpreters/gideros.lua in the zerobrane folder
  • tpropertproper Member
    edited January 2019
    I am still not able to launch the player. I've looked at ZeroBrane's way and have tried the way described here. This is what I'm doing:

    gdrbridge.exe setip 12345
    Launching Gideros Player
    gdrbridge.exe play [my project full path and name with extension]

    What am I forgetting? Also, what does "gdrbridge.exe isconnected" return? I know it returns 1 and 0 but what exactly does that mean? Also, when setting the IP, what exactly is that doing? I'm not sure what I should be setting it to.

    Thanks in advanced!
  • Oh. Nvm. I've got it now.

    Setting the IP is telling the bridge the IP of the Gideros Player (I think) so you set the IP to the player IP and port.

    isconnected tells if the bridge is connected to the player after setting the IP.

    Once I did that, I was able to play from the command line.

    Thanks everyone!

    Likes: antix

    +1 -1 (+1 / -0 )Share on Facebook
Sign In or Register to comment.