Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat | DONATE
Plugin module not found in Mac OS — Gideros Forum

Plugin module not found in Mac OS

gimgim Member
edited May 2014 in Plugins
After copying .dylib files below into /Applications/Gideros/Plugins directory,
require "media" causes error following:
module 'media' not found:
	no field package.preload['media']
	no file './media.lua'
	no file '/usr/local/share/luajit-2.0.2/media.lua'
	no file '/usr/local/share/lua/5.1/media.lua'
	no file '/usr/local/share/lua/5.1/media/init.lua'
	no file './media.so'
	no file '/usr/local/lib/lua/5.1/media.so'
	no file '/usr/local/lib/lua/5.1/loadall.so'
stack traceback:
	main.lua:1: in main chunk
What makes such difference from Windows version? and how can I fix this?


  • ar2rsawseenar2rsawseen Maintainer
    Accepted Answer
    @gim the difference is in the linking process. When there is at least one library that could not be linked, there is no specific error, but simply whole plugin does not work.
    I've had similar report from other user, which had the problem on clean installed Mac.
    While for other users it worked normally.
    It seems there is a dependency on some other library which some seem to have and others don't.

    I will investigate it further and attempt a clean OSX install
  • gimgim Member
    Thanks in advance.

    I'll comment out and bypass such code block for a while. :)
  • I seem to have the same problem on my mac. Following the microphone plugin installation instructions, I've copied
    bin/Mac OS/microphone.dylib
    to the Contents/Plugins folder in the installed Gideros package. I too get the same errors as above:
    scenes/booScene.lua:140: module 'microphone' not found:
    	no field package.preload['microphone']
    	no file './microphone.lua'
    	no file '/usr/local/share/lua/5.1/microphone.lua'
    	no file '/usr/local/share/lua/5.1/microphone/init.lua'
    	no file '/usr/local/lib/lua/5.1/microphone.lua'
    	no file '/usr/local/lib/lua/5.1/microphone/init.lua'
    	no file './microphone.so'
    	no file '/usr/local/lib/lua/5.1/microphone.so'
    	no file '/usr/local/lib/lua/5.1/loadall.so'
    I'm very new to MacOS. This project is working fine on Windows and Android. Am I missing something? Is it related to @ar2rsawseen:s suggestion above?
  • hgy29hgy29 Maintainer
    @saeys, I tried on my Mac and it works for me.
    I copied 'Plugins/microphone.dylib' to' Gideros Player.app/Contents/PlugIns'

Sign In or Register to comment.