Quick Links: Download Gideros Studio | Gideros Documentation | Gideros community chat | DONATE
What to do if I don't get a stack trackback? — Gideros Forum

What to do if I don't get a stack trackback?

piepie Member
edited February 2019 in Bugs and issues
It's pretty strange, it happens inside one asyncCall: suddenly the game crashes but I can't understand exactly "where" because I only get
attempt to call a nil value
stack traceback:
and then nothing else.

I wonder how and if I can avoid such "bug", or if it is somehow expected on certain conditions:
I usually get the whole error message, so I assume it's related to my particular function

Thank you!

[edit p.s. I just tried exporting win32 with console, unfortunately the same output applies]


  • Does it crash when running it inside a windows player? And if so does it not tell you where in the code it is crashing?
  • exactly, windows player and win32 export (console exe).
    Same error but no stack traceback
  • hgy29hgy29 Maintainer
    I have seen it happen when you call Core.asyncCall from within an async call, not sure why though. I fixed it by nesting the Core.asyncCall inside a Timer.delayedCall if called from within a coroutine context
  • Thank you, I will try it asap. :)
    For me it happens (only on certain conditions which I am not able to determine yet) inside an asyncCall that calls itself, so I think it may be the same issue
  • hgy29 nesting Core.asyncCall inside a Timer.delayedCall of 1ms I don't get the error at all. Thank you! :)
    Unfortunately I am not able to replicate the issue in a standalone project to debug it properly: it happens only in a game I'm making.
    Theoretically why do you think it may happen?
    To me it seems that it happens when I break a loop in asyncCall with return, while I am starting the same loop again with different variables: this would explain why delaying the call would fix it. However I don't understand why those loops should be in "conflict" since each one is a local loop.
    If I understood correctly how local functions work, the fact that they share the scope should not be an issue; may it be an issue for Core.asyncCall?

    I'm wondering if it's a good thing to make an extensive use of Timer.delayedCall or if those should be avoided in some other tricky way.

    Thank you!
  • hgy29hgy29 Maintainer
    @pie, I have fixed the asyncCall not being rentrant in gideros for next release, turned out it was a task management issue in gideros code.
    +1 -1 (+4 / -0 )Share on Facebook
  • Cool! Thanks!
Sign In or Register to comment.