Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Plugins are not working in Gideros 2021.1.1 - Gideros Forum

Plugins are not working in Gideros 2021.1.1

I downloaded the latest version of gideros today. I tried to use SceneManager and Easing. However, even adding the plugin to the project and the code written correctly, he says that the function does not exist (he accuses it as "nil"). I went to the gideros installation directory, copied the .lua files from the "All plugins" directory to the "assets" directory of my project and there both worked.

Comments

  • I think you forgot to add :)
    require "scenemanager"
    require "easing"
    https://wiki.gideros.rocks/index.php/SceneManager
    https://wiki.gideros.rocks/index.php/Easing
    my growING GIDEROS github repositories: https://github.com/mokalux?tab=repositories
    +1 -1 (+2 / -0 ) Share on Facebook
  • SinisterSoftSinisterSoft Maintainer
    edited February 2
    You need to also require it in your project.
    require "easing"
    require	"scenemanager"
    Edit:

    That was odd - the forum didn't show your reply @MoKaLux until after I wrote mine!
    (unless it's just too early for me! tired! lol.)

    Likes: MoKaLux, kinrpg

    Coder, video game industry veteran (since the '80s, ❤'s assembler), arrested - never convicted hacker (in the '90s), dad of five, he/him (if that even matters!).
    https://deluxepixel.com
    +1 -1 (+2 / -0 ) Share on Facebook
Sign In or Register to comment.